build/core/build-binary.mk:693: Android NDK: Module jni_pinyinime jni报依赖缺失解决方法

扫一扫,更幸福

APP_ALLOW_MISSING_DEPS=true 错误:

guanlin@ubuntu:~/OpenNI1.5/openni1.5/OpenNI/Platform/Android/jni$ ndk-build Android NDK: android-9 is unsupported. Using minimum supported version android-14.
/home/guanlin/program/android-ndk-r16b/build/core/build-binary.mk:693: Android NDK: Module NiSkeletonBenchmark depends on undefined modules: c usb
/home/guanlin/program/android-ndk-r16b/build/core/build-binary.mk:706: *** Android NDK: Aborting (set APP_ALLOW_MISSING_DEPS=true to allow missing dependencies)    .  Stop.

解决方法:

APP_ALLOW_MISSING_DEPS=true加入makefile中Android.mk 或者Application.mk中。

如果您觉得本文对您有所帮助,可以请小哥哥喝杯茶(*^▽^*)

二维码

发表评论